ADs by Techtunes tAds
ADs by Techtunes tAds

সিসিএনএ অভিযান [পর্ব-১২] :: নেটওয়ার্কিং এ ক্যারিয়ার করতে আগ্রহী, শুধু তাদের জন্য – IPv6

সিসিএনএ অভিযান

অনেক দিন পর .......  😀

ADs by Techtunes tAds

সবাই কেমন আছেন? আশাকরি ভাল আছেন।

চলুন আজকে  IPv6 সর্ম্পকে কিছু জানার চেষ্টা করি।

IPv6 এর বেসিক ধারণা

IPv6 হলো একটি প্রটোকল। IPv6 এর এড্রেস হলো ১২৮ বিটের । ইন্টারনেটে নতুন পরিচয় হিসেবে চালু হলো ইন্টারনেট প্রটোকল ভার্সন ৬ (IPv6) ইন্টারনেট সোসাইটির বরাতে এক খবরে বিবিসি জানিয়েছে, ট্রিলিয়নেরও অধিক ইন্টারনেট ব্যবহারকারীর নিজস্ব আইপি ঠিকানা হিসেবে পরিচিতি দিতেই আইপিভি ৬ চালু হয়েছে।

 কেন IPv6 প্রয়োজন?

আমরা সবাই জানি IPv4 হলো ৩২ বিটের। সুতরাং এর এড্রেসের সংখ্যা হলো ২^৩২ = ৪২৯৪৯৬৭২৯৬ টি। কিন্তু ইন্টারনেট ব্যবহারের সংখ্যা যেভাবে  দিন দিন বৃদ্ধি পাচ্ছে, এই এড্রেসগুলো দ্রুতই শেষ হয়ে যাবে। তাই এই সীমাবদ্ধতা দূর করার জন্য IPv6  এর সংস্করন।

IPv6  এর প্রকারভেদ

১) ইউনিকাস্ট (Unicast)

2)  এনিকাস্ট (Anycast)

ADs by Techtunes tAds

৩)মাল্টিকাস্ট (Multicast)

  • Unicast  আবার তিন প্রকার

১) লিংক লোকাল (Link local) – FE80::/10

২) ইউনিক লোকাল ( Unique local) – FC00::/7 (প্রাইভেট আইপি এড্রেস)

৩) গ্লোবাল ( Global)- পাবলিক আইপি

  • এনিকাস্ট (Anycast)

FE80::1

FE80::2

  • মাল্টিকাস্ট (Multicast)

IPv6  এ মাল্টিকাস্ট এড্রেস হলো  FF00::/8. IPv6 এর এই মাল্টিকাস্টিং এড্রেসকে   IPv4 এর Broadcast  এর সাথে তুলনা করা যায়। অনেকগুলি হোস্টে নিকট কোনো মেসেজ পাঠাতে IPv6 এই মাল্টিকাস্ট ব্যবহার করে। লক্ষ্যণীয় যে  IPv6 এ Broadcast নেই, ফলে মাল্টিকাস্ট অনেক গুরুত্বপূর্ন।

চলুন এবার একটি গুরুত্বর্পুন বিষয় নিয়ে আলোচনা করি। আমাদের IPv4  এর মধ্যে দিয়ে মধ্যে দিয়ে কিভাবে IPv6  এর টানেলিং করা যায়, সেই বিষয়টি দেখি.....

IPv4 এর মধ্য দিয়ে  IPv6 টানেলিং

এ ধরনের একটি নেটওয়ার্কে  কিভাবে টানেলিং করবেন চলুন দেখি

ADs by Techtunes tAds

Router R1 configuration command line

R1(config)#hostname titas1

titas1(config)#enable secret class

titas1(config)#ipv6 unicast-routing

titas1(config)#ipv6 cef

titas1(config)#interface Loopback 0

titas1(config-if)#ip address 1.1.1.1 255.255.255.255

titas1(config-if)#exit

titas1(config)#interface f0/0

titas1(config-if)#ip address 192.168.1.1 255.255.255.252

titas1(config-if)#no shutdown

titas1(config-if)#exit

titas1(config)#interface Serial0/0

titas1(config-if)#encapsulation frame-relay

titas1(config-if)#no shutdown

titas1(config-if)#exit

titas1(config)#interface Serial0/0.1 point-to-point

titas1(config-if)#bandwidth 128

titas1(config-if)#ip address 172.16.1.1 255.255.255.252

titas1(config-if)#ipv6 address C:C:C:C::1/64

titas1(config-if)#ipv6 ospf 1 area 0

titas1(config-if)#frame-relay interface-dlci 181

titas1(config-if)#exit

titas1(config)#interface Serial0/0.2 point-to-point

titas1(config-if)#bandwidth 128

titas1(config-if)#ip address 172.16.2.1 255.255.255.252

titas1(config-if)#ipv6 address D:D:D:D::1/64

titas1(config-if)#ipv6 ospf 1 area 0

titas1(config-if)#frame-relay interface-dlci 182

titas1(config-if)#exit

titas1(config)#ipv6 router ospf 1

titas1(config-rtr)#router-id 1.1.1.1

titas1(config-rtr)#exit

titas1(config)#interface Tunnel 1

titas1(config-if)#ipv6 address B:B:B:B::1/64

titas1(config-if)#ipv6 ospf 1 area 1

titas1(config-if)#tunnel source 192.168.1.1

titas1(config-if)#tunnel destination 192.168.1.2

titas1(config-if)#tunnel mode ipv6ip

titas1(config-if)#exit

titas1(config)#line vty 0 4

titas1(config-line)#password cisco

titas1(config-line)#login

titas1(config-line)#exit

Router R2 configuration command line

R2(config)#hostname titas2

titas2(config)#enable secret class

titas2(config)#ipv6 unicast-routing

titas2(config)#ipv6 cef

titas2(config)#interface Loopback 0

titas2(config-if)#ip address 2.2.2.2 255.255.255.255

titas2(config-if)#exit

titas2(config)#interface f0/0

titas2(config-if)#ip address 192.168.1.2 255.255.255.252

titas2(config-if)#no shutdown

titas2(config-if)#exit

titas2(config)#interface f0/1

titas2(config-if)#ip address 10.1.2.2 255.255.255.0

titas2(config-if)#ipv6 address A:A:A:A::2/64

titas2(config-if)#ipv6 ospf 1 area 1

titas2(config-if)#no shutdown

titas2(config-if)#exit

titas2(config)#ipv6 router ospf 1

titas2(config-rtr)#router-id 2.2.2.2

titas2(config-rtr)#exit

titas2(config)#interface Tunnel 1

titas2(config-if)#ipv6 address B:B:B:B::2/64

titas2(config-if)#ipv6 ospf 1 area 1

titas2(config-if)#tunnel source 192.168.1.2

titas2(config-if)#tunnel destination 192.168.1.1

titas2(config-if)#tunnel mode ipv6ip

titas2(config-if)#exit

titas2(config)#line vty 0 4

titas2(config-line)#password cisco

titas2(config-line)#login

titas2(config-line)#exit

Router R3 configuration command line

R3(config)#hostname titas3

titas3(config)#enable secret class

titas3(config)#ipv6 unicast-routing

titas3(config)#ipv6 cef

titas3(config)#interface Loopback 0

titas3(config-if)#ip address 3.3.3.3 255.255.255.255

titas3(config-if)#exit

titas3(config)#interface Serial0/0

titas3(config-if)#encapsulation frame-relay

titas3(config-if)#no shutdown

titas3(config-if)#exit

titas3(config)#interface Serial0/0.1 point-to-point

titas3(config-if)#bandwidth 256

titas3(config-if)#ip address 10.1.1.1 255.255.255.252

titas3(config-if)#ipv6 address E:E:E:E::1/64

titas3(config-if)#ipv6 ospf 1 area 0

titas3(config-if)#frame-relay interface-dlci 881

titas3(config-if)#exit

titas3(config)#interface Serial0/0.2 point-to-point

titas3(config-if)#bandwidth 128

titas3(config-if)#ip address 172.16.1.2 255.255.255.252

titas3(config-if)#ipv6 address C:C:C:C::2/64

titas3(config-if)#ipv6 ospf 1 area 0

titas3(config-if)#frame-relay interface-dlci 811

titas3(config-if)#exit

titas3(config)#ipv6 router ospf 1

titas3(config-rtr)#router-id 3.3.3.3

titas3(config-rtr)#exit

titas3(config)#line vty 0 4

titas3(config-line)#password cisco

titas3(config-line)#login

titas3(config-line)#exit

Router R4 configuration command line

R4(config)#hostname titas4

titas4(config)#enable secret class

titas4(config)#ipv6 unicast-routing

titas4(config)#ipv6 cef

titas4(config)#interface Loopback 0

titas4(config-if)#ip address 4.4.4.4 255.255.255.255

titas4(config-if)#exit

titas4(config)#interface Serial0/0

titas4(config-if)#encapsulation frame-relay

titas4(config-if)#no shutdown

titas4(config-if)#exit

titas4(config)#interface Serial0/0.1 point-to-point

titas4(config-if)#bandwidth 256

titas4(config-if)#ip address 10.1.1.2 255.255.255.252

titas4(config-if)#ipv6 address E:E:E:E::2/64

titas4(config-if)#ipv6 ospf 1 area 0

titas4(config-if)#frame-relay interface-dlci 882

titas4(config-if)#exit

titas4(config)#interface Serial0/0.2 point-to-point

titas4(config-if)#bandwidth 128

titas4(config-if)#ip address 172.16.2.2 255.255.255.252

titas4(config-if)#ipv6 address D:D:D:D::2/64

titas4(config-if)#ipv6 ospf 1 area 0

titas4(config-if)#frame-relay interface-dlci 821

titas4(config-if)#exit

titas4(config)#ipv6 router ospf 1

titas4(config-rtr)#router-id 4.4.4.4

titas4(config-rtr)#exit

titas4(config)#line vty 0 4

titas4(config-line)#password cisco

titas4(config-line)#login

titas4(config-line)#exit

আজকের মতো এখানেই শেষ করলাম । সবাই ভাল থাকবেন .......  🙂

ADs by Techtunes tAds
Level 0

আমি তিতাস। বিশ্বের সর্ববৃহৎ বিজ্ঞান ও প্রযুক্তির সৌশল নেটওয়ার্ক - টেকটিউনস এ আমি 8 বছর 9 মাস যাবৎ যুক্ত আছি। টেকটিউনস আমি এ পর্যন্ত 20 টি টিউন ও 123 টি টিউমেন্ট করেছি। টেকটিউনসে আমার 0 ফলোয়ার আছে এবং আমি টেকটিউনসে 0 টিউনারকে ফলো করি।

তিতাস একটি নদীর নাম ............


আরও টিউনস


টিউনারের আরও টিউনস


টিউমেন্টস

vai ccna AIUB theke korbo na buet?

    চলুন নিজে নিজেই শিখি।

    @net_freak: আপনার বাসার কাছাকাছি যেটা আছে সেটাতে ভর্তি হয়ে যান । এই কোর্স টা মোটামুটি সব জায়গায় একি রকম । তবে AIUB তে ল্যাব ফ্যাসিলিটি ভাল । আর সবচেয়ে ভাল তিতাস ভাইকে বিরক্ত করেন 😀 বস পাবলিক

thanks

Idea টা interesting……But …… এটা খুব যে কাজে দিবে তা কিন্তু না………cz আমার ধারনা

1.it may occur IP conflict when one ip uses by two user in same network(when two pc alive), as a result no one getting internet properly as well as itz really tough to monitor কোন user ইউজার এখন করছে না।

2.Most of local ISP now using cisco intellegent switch and create VLAN(virtual are network) for different series as well as diffirent package. so,আপনি যে IP or যে MAC ই use করেন না কেন speed must be same পাবেন, i think so.

Riyad vai, eta amar ধারনা। how can we overcome that……..

titas vai,
ager commenta vule post hoye gese.sorry 4 dat………..thanx 4 ur ccna Ovizan………

Welcome !

অনেকদিন পর 😀 আমি তো ভাবলাম আর টিউন করবেন না । যাই হোক শুভকামনা রইল । আশা করছি ভেনডোর এক্সাম দেয়ার আগ পর্যন্ত এখন সাথে থাকবেন । 😀 😀

ধন্যবাদ

What is IPv6? Features

All right, so first and foremost with IP version 6 – we have many, many more addresses. How many? Too many to count, way too many to count. But let’s put it in perspective, an IP version 4 was how many bits? Just 32 bits. IP version 6 addresses are 128 bits. That’s a significant increase in size…

to know moe about IP V6 follow this link

http://www.learncisco.net/courses/icnd-1/introducing-ipv6/the-ipv6-address.html