ADs by Techtunes ADs
ADs by Techtunes ADs

সিসিএনএ অভিযান [পর্ব-১৩] :: নেটওয়ার্কিং এ ক্যারিয়ার করতে আগ্রহী, শুধু তাদের জন্য – WAN

সিসিএনএ অভিযান

ADs by Techtunes ADs

WAN(Wide Area Network)

আমার তো আগেই জেনেছি যে, দূরবর্তী ল্যানসমূকে নিয়ে গড়ে উঠা নেটওয়ার্ককে ওয়াইড এরিয়া নেটওয়ার্ক বলে। এ ধরনের নেটওয়ার্ক এর ডাটা ট্রান্সফার স্পীড ৫৬ কেবিপিএস থেকে ১.৫৪৪এমবিপিএস হয়ে থাকে। ওয়্যানের গতি ধীরে ধীরে পরিবর্তন হচ্ছে। এ ধরনের নেটওয়ার্কে ব্যবহিত ডিভাইসগুলো হলো রাউটার, মডেম, ওয়্যান সুইজ ইত্যাদি।

WAN কেন প্রয়োজন?

একাধিক দূরবর্তী নেটওর্য়াক গুলোর মধ্যে রিসোর্স শেয়ার করার জন্য WAN প্রয়োজন. ধরেন আপনার অফিসের কয়েকটি সাব অফিস বিভিন্ন স্থানে রয়েছে এখন যদি আপনি সাব অফিস গুলোর রিসোর্স ব্যবহার করতে চান তাহলে আপনার ওয়্যান কানেক্টিভিটি প্রয়োজন।

 কি কি টাইপের WAN  কানেকশন হয়?

  • ডেডিকেটেড লিজড লাইন কানেশন
  • সার্কিট সুইজড কানেকশন
  • প্যাকেট সুইচড কানেকশন

ডেডিকেটেড লিজড লাইন কানেশন

ডেডিকেটেড লিজড লাইন কানেশন হলো এক জন কাস্টমার কর্তৃক ব্যবহিত হয়। কাস্টমার সার্ভিস প্রভাইডার এর নিকট থেকে নিদির্র্ষ্ট সময় এর জন্য ভাড়া নেয়। ইহা হলো সাধারণত পয়েন্ট টু পয়েন্ট কানেশন।

সার্কিট সুইজড কানেকশন

ADs by Techtunes ADs

সার্কিট সুইজড কানেকশন হলো টেলিফোন কানেকশন এই কানেকশন একবার স্থাপন হলে  সংযোগ বিচ্ছিন্ন না হওয়া পর্যন্ত ব্যস্ত থাকে। এই কানেকশনের সুবিধা হলো কোন ইন্টারপারেন্স নেই, ডেডিকেটেড অবস্থায় কল থাকে। ফলে সকল ব্যান্ডওয়াই ব্যবহার হয় এবং শেয়ারেই এর জামেলা নাই। তবে অসুবিধা হলো যদি জরুরী কোন স্থাপন করার প্রয়োজন হয় তাহলে তা স্থাপন করা সম্ভব নয় যদি কানেকশন ব্যস্ত থাকে ।

প্যাকেট সুইচড কানেকশন

প্যাকেট সুইচড কানেকশন এ  ম্যাসেজটা ছোট ছোট প্যাকেটে পরিণত হয় এবং প্যাকেট গুলো একাধিক পথ দিয়ে গমন করে তাই কোন পথে যদি সমস্যা থাকে তাহলে অন্য পথ দিয়ে গমন করে। প্রত্যেকটি প্যাকেট এর সাথে হেডার সংযুক্ত থাকে ফলে রিসিভার হেডারগুলো দেখে দেখে ম্যাসেজ গ্রহন করে। এর প্রধান সুবিধা হলো যেহেতু একাধিক পথ থাকে ফলে রিসিভার দেরিতে হলেও ম্যাসেজ পায়। এর অসুবিধা হলো রিয়েল টাইম যোগাযোগ এর সময় কোন কাজে আসে না।

এতক্ষন আমরা দেখলাম WAN কি , কেন আমরা WAN কনিফগার করি এবং এই WAN  কি কি টাইপের হয়। এখন সম্ভবতই প্রশ্ন আসে WAN  কিভাবে কনফিগার করা যায়।  তাই আজকে আমরা দেখব Point to Point Protocol(PPP) এর মাধ্যমে কিভাবে WAN কনফিগার করা যায়। চলুন তাহলে শুরু করা যাক

আজকে আমরা দেখবো WAN এ PPP কিভাবে কনফিগার করা যায় সাথে CHAP authentication

প্রথমেই ইন্টারফেস গুলো আপ করি

Interface configuration of Titas router

ADs by Techtunes ADs

Router>en

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname titas

titas(config)#interface serial 0/0/0

titas(config-if)#ip address 192.168.12.1 255.255.255.0

titas(config-if)#clock rate 64000

titas(config)#interface fastEthernet 0/0

titas(config-if)#ip address 192.168.10.1 255.255.255.0

titas(config-if)#no shutdown

ADs by Techtunes ADs

Interface configuration of sarker router

Router>en

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname sarker

sarker(config)#interface serial 0/0/0

sarker(config-if)#ip address 192.168.12.2 255.255.255.0

sarker(config-if)#no shutdown

sarker(config)#interface fas

sarker(config)#interface fastEthernet 0/0

ADs by Techtunes ADs

sarker(config-if)#ip add

sarker(config-if)#ip addr

sarker(config-if)#ip address 192.168.11.1 255.255.255.0

sarker(config-if)#no sh

sarker(config-if)#no shutdown

Routing configure for titas router

titas(config)#router rip

titas(config-router)#network 192.168.12.0

titas(config-router)#network 192.168.10.0

Routing configure for sarker router

ADs by Techtunes ADs

sarker(config)#router rip

sarker(config-router)#network 192.168.12.0

sarker(config-router)#network 192.168.11.0

এখন চলুন PPP configure করি

Configure PPP in titas router with CHAP authentication

titas#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

titas(config)#username titas pass

titas(config)#username titas password 123456

titas(config)#interface serial 0/0/0

ADs by Techtunes ADs

titas(config-if)#encapsulation ppp

titas(config-if)#

titas(config-if)#ppp authentication chap

titas(config-if)#exit

Configure PPP in sarker router with CHAP authentication

sarker#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

sarker(config)#username sarker password 123456

sarker(config)#interface serial 0/0/0

sarker(config-if)#encapsulation ppp

ADs by Techtunes ADs

sarker(config-if)#ppp authentication chap

----------------------------------------------------------------------------------

Stay Happy, Stay Healthy!!

 

ADs by Techtunes ADs
Level 0

আমি তিতাস। বিশ্বের সর্ববৃহৎ বিজ্ঞান ও প্রযুক্তির সৌশল নেটওয়ার্ক - টেকটিউনস এ আমি 9 বছর 9 মাস যাবৎ যুক্ত আছি। টেকটিউনস আমি এ পর্যন্ত 20 টি টিউন ও 122 টি টিউমেন্ট করেছি। টেকটিউনসে আমার 1 ফলোয়ার আছে এবং আমি টেকটিউনসে 0 টিউনারকে ফলো করি।

তিতাস একটি নদীর নাম ............


টিউনস


আরও টিউনস


টিউনারের আরও টিউনস


টিউমেন্টস

ভাইয়া, কিছু মনে কইরেন না, কিছু কথা বলি। আপনি কিছু কমান্ড দিয়েছেন, ভাল কথা, কিন্তু যেই টপলজি(প্রশ্ন) দেখে নেটওয়ার্ক করেছেন্‌ সেইটা দেয়ার দরকার ছিল, বলে আমি মনে করি। না হলে যারা পোস্টটা পড়বে তারা কিছুই বুঝবে না। আরেকটা কথা আপনি যে Packet tracer এর স্ক্রিন শট টা দিয়েছেন, সেখানে, রউটার এর নাম গুলো রিনেম করে দিলে ভাল হত।
রাউটারে যে রিপ প্রোটোকল চালিয়েছেন অইটার ভার্সন (১ না ২) বলে দিলে ভাল হত।
সর্বোপরি পোস্ট করার জন্য ধন্যবাদ।

ধন্যবাদ ভাই, টিউনটি সুন্দরভাবে পড়ে তারপর মন্তব্য করার জন্য। এখানে Point to Point Protocol(PPP) এর মাধ্যমে কিভাবে WAN কনফিগার করা যায় সেই বিষয়টি বোঝানোর চেষ্টা করেছি। এখানে titas নামে একটি রাউটার আরেকটি রাউটার এর নাম sarker । আমি রাউটার এর স্ক্রিন শট এর উপরে নাম দিয়ে দিয়েছি, সাথে সাথে ইন্টারফেইজ এর আইপি এ্যাড্রেস গুলোও দিয়ে দিয়েছি। এখানে রিপ ভার্সন ১ ব্যবহার করা হয়েছে। আপনি যদি কমান্ডগুলো দেখেন তাহলে দেখবেন লিখা আছে router rip. আর রিপ ভার্সন ২ এর কমান্ড হলো router rip version 2 । আশাকরি বোঝতে পেরেছেন। ভাল থাকবেন।

tnkzzzzz, upokar pelam,continue karun

স্বাগতম। ঠিক আছে।

মাই ভার্চুয়াল ইন্সট্রাক্টর 😀
আচ্ছা নিচের এই লাইন এর পর এটা ইউস করলে কেমন হয় ?
titas(config-if)#no shutdown
titas(config-if)#exit যদিও তেমন কোন ইফেক্ট হয় বলে মনে হয় না তবুও । কি বলেন 🙂

মুন্না ভাই, no shutdown কমান্ডটি ব্যবহার করা ইন্টারফেসটিকে আপ করার জন্য । আর exit কমান্ডটি ব্যবহার করা হয় ইন্টারফেস থেকে বের হয়ে আসার জন্য।