ADs by Techtunes ADs
ADs by Techtunes ADs

সিসিএনএ অভিযান [পর্ব-১৪] :: নেটওয়ার্কিং এ ক্যারিয়ার করতে আগ্রহী, শুধু তাদের জন্য- (HSRP,VRRP, GLBP)

আজকে আমরা দেখবো কিভাবে দুইটি Gateway রাউটার কনফিগার করতে হয় অর্থাৎ একটি Gateway রাউটার অকেজো হয়ে গেলেও আরেকটি রাউটার কিভাবে কানেক্টটিভিটি একটিভ রাখে।

ADs by Techtunes ADs

চলেন প্রথমে আমরা High availability নিয়ে একটু জানার চেষ্টা করি।
High availability হলো পর্যাপ্ততা। অথার্ৎ সব সময়েই পাওয়া যাবে। মানে কোন একটি পাথ অকেজো হলেও অন্য একটি পাথ দিয়ে যোগাযোগ রক্ষা হবে। নেটওয়ার্কি এর ক্ষেত্রে এই গুরুত্বপূর্ণ কাজটি করার জন্য যে প্রোটকলগুলো ব্যবহার করা সেই প্রটোকল গুলোই হলো HSRP, VRRP, GLBP ইত্যাদি। আজকে আমরা এই প্রোটকলগুলো নিয়েই আলোচনা করব।

Hot Standby Router Protocol (HSRP)
HSRP হলো সিসকো প্রোপ্রাইটারী প্রটোকল। এই প্রটোকল যে কাজটি করে তা হলো যদি দুইটি রাউটার থাকে তাহলে একটি রাউটারকে একটিভ আরেকটি রাউটারকে স্ট্যান্ডবাই রাখে। ফলে একটি রাউটার যদি কাজ না করে তাহলে অন্য রাউটার দিয়ে কাজ সর্ম্পূণ হয়।
চলেন তাহলে দেখি HSRP কিভাবে কাজ করে,
মনেকরি আমাদের নেটওয়ার্কটি দেখতে নীচের ছবিটির মত। যেখানে দুইটি রাউটার আছে। অথার্ৎ রাউটার R1একটিভ থাকবে এবং আরেকটি রাউটার (R2) স্ট্যান্ডবাই আছে।

 

 

এখন যদি একটি রাউটার(R1) অকেজো হয়ে যায় স্ট্যান্ডবাই রাউটার একটিভ মোডে রুপান্তর হয়ে যাবে।


Virtual Router Redundancy Protocol (VRRP)
VRRP হলো ওপেন স্ট্যার্ন্ডাড প্রটোকল। ইহার ফাংশনালিটি HSRP এর মত। অর্থাৎ এই প্রটোকলও যে কাজটি করে তা হলো যদি দুইটি রাউটার থাকে তাহলে একটি রাউটারকে একটিভ আরেকটি রাউটারকে স্ট্যান্ডবাই রাখে। ফলে একটি রাউটার যদি কাজ না করে তাহলে অন্য রাউটার দিয়ে কাজ সর্ম্পূণ হয়।

Gateway Load Balancing Protocol (GLBP)
GLBP হলো ওপেন স্ট্যার্ন্ডাড প্রটোকল। এই প্রটোকলও যে কাজটি করে তা হলো যদি দুইটি রাউটার থাকে তাহলে দুইটি রাউটারকে একটিভ রাখে এবং লোড ব্যালেন্স করে থাকে।

চলেন তাহলে দেখি GLBP কিভাবে কাজ করে
GLBP যদি দুইটি রাউটার থাকে তাহলে দুইটি রাউটারকে একটিভ রাখে এবং লোড ব্যালেন্স করে থাকে।

ADs by Techtunes ADs


এখন যদি একটি রাউটার(R1) অকেজো হয়ে যায় অন্য রাউটার দিয়ে সকল প্যাকেট ট্রান্সফার হয়ে থাকে।

 

আমরা আজকে দেখব কিভাবে HSRP কনফিগার করতে হয়।

প্রথমে আমরা নেটওয়ার্কটি ডিজাইন করি


কনফিগারেশন
HSRP Router1 interface configuration command line :
Router>en
Router#conf
Router#configure ter
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# host
Router(config)# hostname HSRPRouter1
HSRPRouter1(config)# inter
HSRPRouter1(config)# interface gi
HSRPRouter1(config)# interface gigabitEthernet 0/0
HSRPRouter1(config-if)# ip add
HSRPRouter1(config-if)# ip address 192.168.1.3 255.255.255.0
HSRPRouter1(config-if)# no sh
HSRPRouter1(config-if)# no shutdown
HSRPRouter1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
HSRPRouter1(config-if)#
HSRPRouter1(config-if)# exit
HSRPRouter1(config)# inter
HSRPRouter1(config)# interface gi
HSRPRouter1(config)# interface gigabitEthernet 0/1
HSRPRouter1(config-if)# ip add
HSRPRouter1(config-if)# ip address 1.1.1.1 255.255.255.0
HSRPRouter1(config-if)# no sh
HSRPRouter1(config-if)# no shutdown
HSRPRouter1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
exit

HSRP Router2 interface configuration command line
Router>
Router>en
Router#conf
Router#configure ter
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
Router(config)#
Router(config)#
Router(config)# inter
Router(config)# interface gig
Router(config)# interface gigabitEthernet 0/0
Router(config-if)# ip add
Router(config-if)# ip address 192.168.1.2 255.255.255.0
Router(config-if)# no sh
Router(config-if)# no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
Router(config-if)# exit
Router(config)# inter
Router(config)# interface fast
Router(config)# interface gi
Router(config)# interface gigabitEthernet 0/1
Router(config-if)# ip add
Router(config-if)# ip address 1.1.1.2 255.255.255.0
Router(config-if)# no sh
Router(config-if)# no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
Router(config-if)# exit
Router(config)# hos
Router(config)# hostname HSRPRouter2

ISP router interface configuration command line
Router>en
Router#conf
Router#configure ter
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# host
Router(config)# hostname ISP
ISP(config)# inter
ISP(config)# interface gi
ISP(config)# nterface gigabitEthernet 0/1
ISP(config-if)# ip add
ISP(config-if)# ip address 1.1.1.3 255.255.255.0
ISP(config-if)# no sh
ISP(config-if)# no shutdown
ISP(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up

Routing configuration for ISP router
ISP(config)# ip route 0.0.0.0 0.0.0.0 gigabitEthernet 0/1

HSRP configuration command line for HSRP Router1

ADs by Techtunes ADs

HSRPRouter1(config)# inter
HSRPRouter1(config)# interface gi
HSRPRouter1(config)# interface gigabitEthernet 0/0
HSRPRouter1(config-if)# st
HSRPRouter1(config-if)# standby 1 ip 192.168.1.254

HSRP configuration command line for HSRPRouter2
Router(config)# hos
Router(config)# hostname HSRPRouter2
HSRPRouter2(config)#
HSRPRouter2(config)#
HSRPRouter2(config)#
HSRPRouter2(config)# inter
HSRPRouter2(config)# interface gi
HSRPRouter2(config)# interface gigabitEthernet 0/0
HSRPRouter2(config-if)# stan
HSRPRouter2(config-if)# standby 1 ip 192.168.1.254
HSRPRouter2(config-if)#

!!Best wishes!!

ADs by Techtunes ADs
Level 0

আমি তিতাস। বিশ্বের সর্ববৃহৎ বিজ্ঞান ও প্রযুক্তির সৌশল নেটওয়ার্ক - টেকটিউনস এ আমি 9 বছর 9 মাস যাবৎ যুক্ত আছি। টেকটিউনস আমি এ পর্যন্ত 20 টি টিউন ও 122 টি টিউমেন্ট করেছি। টেকটিউনসে আমার 1 ফলোয়ার আছে এবং আমি টেকটিউনসে 0 টিউনারকে ফলো করি।

তিতাস একটি নদীর নাম ............


টিউনস


আরও টিউনস


টিউনারের আরও টিউনস


টিউমেন্টস

বাংলাদেশকে বিজয়ী করতে প্রয়োজন আপনার ভোট। প্রযুক্তিপ্রেমী তরুণ প্রজন্ম কি একবার সাড়া দেবে ? এসো সবাই মিলে বিজয়ী করি বাংলাদেশকে। বিশ্বকে জানিয়ে দেই আমরাই চ্যাম্পিয়ন
https://www.techtunes.co/tech-talk/tune-id/438763

ধন্যবাদ ভাই।আগের সিরিজগুলা একসাথে পাইলে ভাল হত