ADs by Techtunes ADs
ADs by Techtunes ADs

সিসিএনএ অভিযান :: নেটওয়ার্কিং এ ক্যারিয়ার করতে আগ্রহী, শুধু তাদের জন্য – OSPF [অভিযান-১০]

সিসিএনএ অভিযান

ADs by Techtunes ADs

Area 0  হলো যেখানে Backbone router গুলো থাকে। Area 0 এর সাথে Area border Router গুলো সংযুক্ত থাকে। অন্য কোন রাউটিং ডোমেন এর সাথে সংযুক্ত হওয়ার জন্য Autonomous System border Router ব্যবহার করা হয়।প্রত্যেক এরিয়াতে আবার Designated router আর Backup Designated router থাকে।

ওএসপিএফ কি?

ওএসপিএফ হলো ওপেন শর্টেস্ট পাথ ফার্স্ট একটি লিঙ্ক স্টেট রাউটিং প্রটোকল যা ওপেন স্ট্যান্ডার্ডের উপর ভিত্তি করে গড়ে উঠেছে।তাই এটি সিসকোসহ অন্যান্য রাউটারেও কাজ করে। ওএসপিএফ ব্যাপকভাবে ইনটেরিয়র গেটওয়ে প্রটোকল হিসেবে ব্যবহিত হয়ে থাকে, বিশেষকরে বড় নেটওয়ার্কে।

ওএসপিএফ এর বৈশিষ্ট্যসমুহ:

  • ওএসপিএফ রাউটিং ডোমেইনকে এরিয়াতে বিভক্ত করে।
  • কেবল রাউট পরিবর্তনের সময় রাউট আপডেট ঘটে।
  • যে রাউট বদলেছে কেবল সেটির তথ্য থাকে এলএসএ(LSA)(লিংক স্টেট অ্যাডভার্টাইমেন্ট) এ।
  • প্রতিবেশী গড়ে তোলার জন্য হ্যালো(Hello) মেসেজ বিনিময় করে।
  • ওএসপিএফ ভ্যারিয়েবল লেংথ  সাবনেট মাস্ক(VLSM) এবং ক্লাসলেস ইন্টার ডোমেইন রাউটিং (CIDR)সাপোর্ট করে।
  • ওএসপিএফ অসংখ্য নেটওয়ার্ক হোপ সমর্থন করে।
  • ওএসপিএফ এর মাল্টিকাস্ট এড্রেস হলো(২২৪.০.০.৫ এবং ২২৪.০.০.৬)
  • ইহায় ব্যবহিত এলগ্যারিদম হলো ডিজেক্সট্রা শর্টেস্ট পাথ ফার্স্ট।

ওওসপিএফ এর টেবিলসমূহ:

ওএসপিএফ তিনটি টেবিল ব্যবহার করে- প্রতিবেশী টেবিল, লিংক স্টেট টেবিল এবং রাউটিং টেবিল। এই তিনটি টেবিলের সমন্বয়ে ওওসপিএফ পুরো নেটওর্য়াকের চিত্র পায়।

  • প্রতিবেশী টেবিল(Neighbors table):

কোন রাউটারের আসে পাশে কোন রাউটার আছে সে সম্পকির্ত তথ্য থাকে এই টেবিলে।

  • লিংক স্টেট টেবিল(Link-state table):

প্রতিবেশী রাউটার সমুহের সাথে যুক্ত লিংকসমুহের কোনটির অবস্থা কেমন সে সম্পর্কিত তথ্য রাখা হয় এই টেবিলে।

  • রাউটিং টেবিল(Routing table):

লিংক স্টেট টেবিলে যেসব লিংকের তথ্য থাকবে সেগুলোর প্রতিটির ব্যয় কত হবে সে সম্পর্কিত তথ্য থাকবে রাউটিং টেবিলে।

চলুন এবার একটি Lab করি:

Host name and IP address কনফিগারেশন ইন রাউটার-১:

Router>en

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname titas

titas(config)#interface fastEthernet 0/0

titas(config-if)#ip address 192.168.10.1 255.255.255.0

titas(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

titas(config-if)#exit

titas(config)#interface fastEthernet 0/1

titas(config-if)#ip address 192.168.11.1 255.255.255.0

titas(config-if)#no shutdown

titas(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

titas(config-if)#exit

titas(config)#exit

%SYS-5-CONFIG_I: Configured from console by console

titas#wr

Building configuration...

[OK]

titas#reload

Host name and IP address কনফিগারেশন ইন রাউটার-২:

Router>en

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#hostname sarker

sarker(config)#interface fastEthernet 0/0

sarker(config-if)#ip address 192.168.10.2 255.255.255.0

sarker(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

sarker(config-if)#exit

sarker(config)#interface fastEthernet 0/1

sarker(config-if)#ip address 192.168.12.1 255.255.255.0

sarker(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

sarker(config-if)#exit

sarker(config)#exit

%SYS-5-CONFIG_I: Configured from console by console

sarker#wr

Building configuration...

[OK]

sarker#reload

Open Shortest Path Fast (OSPF) Protocol কনফিগারেশন ইন রাউটার-১:

For R1

titas>en

titas#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

titas(config)#router ospf 1

titas(config-router)#network 192.168.10.0 0.0.0.255 area 0

titas(config-router)#network 192.168.11.0 0.0.0.255 area 0

titas(config-router)#exit

titas(config)#exit

%SYS-5-CONFIG_I: Configured from console by console

titas#wr

Building configuration...

[OK]

titas#

Open Shortest Path Fast (OSPF) Protocol কনফিগারেশন ইন রাউটার-2:

sarker>en

sarker#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

sarker(config)#router ospf 1

sarker(config-router)#network 192.168.10.0 0.0.0.255 area 0

sarker(config-router)#network 192.168.10.0 0.0.0.255 area 0

00:05:34: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.11.1 on FastEthernet0/0 from LOADING to FULL, Loading Done

sarker(config-router)#network 192.168.12.0 0.0.0.255 area 0

sarker(config-router)#exit

sarker(config)#exit

%SYS-5-CONFIG_I: Configured from console by console

sarker#wr

Building configuration...

[OK]

Verify connectivity with ping command :

Have a nice day for all.................. 😎 :

ADs by Techtunes ADs

ADs by Techtunes ADs
Level 0

আমি তিতাস। বিশ্বের সর্ববৃহৎ বিজ্ঞান ও প্রযুক্তির সৌশল নেটওয়ার্ক - টেকটিউনস এ আমি 9 বছর 9 মাস যাবৎ যুক্ত আছি। টেকটিউনস আমি এ পর্যন্ত 20 টি টিউন ও 122 টি টিউমেন্ট করেছি। টেকটিউনসে আমার 1 ফলোয়ার আছে এবং আমি টেকটিউনসে 0 টিউনারকে ফলো করি।

তিতাস একটি নদীর নাম ............


টিউনস


আরও টিউনস


টিউনারের আরও টিউনস


টিউমেন্টস

তিতাস ভাই অনেক দিন পর আপনার টিউন পেলাম। আপনার টিউনের রুমে মাঝে মাঝে ডু মারি। ধন্যবাদ আপনার ধারাবাহিক টিউন করার জন্য।

CCNA অনেক সুন্দর একটা কোর্চ, আমি এটা করেছি। এবং তোমাদের সাহায্য করতে চায়। CCNA এর online exam এর কিছু প্রশ্ন ও উত্তর। ওয়েব সাইট http://www.CiscoDesk.blogspot.com facebook page is http://facebook.com/ciscodesk । সিসকো সম্পকে অনেক তথ্য পাবেন।

    ধন্যবাদ ভাই শেয়ার করার জন্য।

      @তিতাস: Vi তোমাকেউ ধন্যবাদ। তুমি এই সাইটে http://ciscoDesk.blogspot.com লিখতে পার। সিসকো student দের উপকার হবে। এই সাইটে একটা VLSM calculator বা sub netting & CCNA ম্যাটেরিয়াল আছে।

      তুমি অনেক ভা্ল একটা উদ্দ্যোক নিয়েছ।

ওকে ব্রাদার।

একটা পরামর্শ দেন ভাই্ । সিসিএন কোথায় করা যেতে পারে । আ্মি ব্যসিক নেটওয়র্কিং জানি । একটা অফিসে আছি এ পদেই । সার্ভার বানানো টুকটাক পারি । পুর্নাঙ্গ ক্যারিয়ার করতে চাইলে এ বিদ্যায় চলবেনা বুঝতে পারছি । কিভাবে কি করা যায় একটু সাজেস্ট করলে উপকার হয় । ধন্যবাদ ।

আরেকটা কথা আমি পড়াশুনা কিন্তু কমার্স ….গ্যাজুয়েট । কেমন করে যেনে আইটা তে চলে আসা ।

Level 0

তিতাস ভাই সিসিএন এ নিয়ে আরও বিস্তারিত লিখুন।

তিতাস ভাই VLSM এর পর OSPF।ভাল লাগল কিন্ত এটা অনেক কঠিন্‌…

ভাল লাগল